GrowlMail on Snow Leopard

Since upgrading to Snow Leopard I don't get the beloved GrowlMail popups anymore, because the GrowlMail application does not work under Snow Leopard, yet.

But, there are a thousand ways to skin a cat, as this cuddly proverb knows. Mail Rules and Applescript can compensate for the lack of GrowlMail.


There's actually a fix for Growl 1.2 and Mail 4.2, to be found here

For a global installation

defaults write /Library/Mail/Bundles/GrowlMail.mailbundle/Contents/Info SupportedPluginCompatibilityUUIDs -array-add "2F0CF6F9-35BA-4812-9CB2-155C0FDB9B0F"
defaults write /Library/Mail/Bundles/GrowlMail.mailbundle/Contents/Info SupportedPluginCompatibilityUUIDs -array-add "0CB5F2A0-A173-4809-86E3-9317261F1745"